[Resolved] Delay in sending Notifications

Incident Report for Zenduty

Resolved

[Resolved] Users may have experienced a delay in receiving notifications. This issue was identified at 12:43 PM GMT and was resolved by 1:03 PM GMT.
Posted Mar 20, 2025 - 12:30 UTC